const regex = /\$(\d+)[\,]*([\.]*\d*)/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$(\\d+)[\\,]*([\\.]*\\d*)', 'igm')
const str = `a|b|c
\$1,000|hi,you|\$45.43
\$300.03|\$MS2|\$55,000`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);