import Foundation
let pattern = #"\$(\d+)[\,]*([\.]*\d*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
a|b|c
$1,000|hi,you|$45.43
$300.03|$MS2|$55,000
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)