using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" +<metaData>[\S\s]+<\/metaData>\s";
string input = @" <usedInTechSheet>false</usedInTechSheet>
<usedInCompositionList>false</usedInCompositionList>
<usedInRequestForm>false</usedInRequestForm>
<metaData>
<dateCreation>2014-10-01</dateCreation>
<dateMaj>2021-04-27</dateMaj>
</metaData>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}