import re
regex = re.compile(r" +<metaData>[\S\s]+<\/metaData>\s")
test_str = (" <usedInTechSheet>false</usedInTechSheet>\n"
" <usedInCompositionList>false</usedInCompositionList>\n"
" <usedInRequestForm>false</usedInRequestForm>\n"
" <metaData>\n"
" <dateCreation>2014-10-01</dateCreation>\n"
" <dateMaj>2021-04-27</dateMaj>\n"
" </metaData>\n"
" ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")