package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(` +<metaData>[\S\s]+<\/metaData>\s`)
var str = ` <usedInTechSheet>false</usedInTechSheet>
<usedInCompositionList>false</usedInCompositionList>
<usedInRequestForm>false</usedInRequestForm>
<metaData>
<dateCreation>2014-10-01</dateCreation>
<dateMaj>2021-04-27</dateMaj>
</metaData>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}