import Foundation
let pattern = #" +<metaData>[\S\s]+<\/metaData>\s"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<usedInTechSheet>false</usedInTechSheet>
<usedInCompositionList>false</usedInCompositionList>
<usedInRequestForm>false</usedInRequestForm>
<metaData>
<dateCreation>2014-10-01</dateCreation>
<dateMaj>2021-04-27</dateMaj>
</metaData>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)