use strict;
my $str = ' <usedInTechSheet>false</usedInTechSheet>
<usedInCompositionList>false</usedInCompositionList>
<usedInRequestForm>false</usedInRequestForm>
<metaData>
<dateCreation>2014-10-01</dateCreation>
<dateMaj>2021-04-27</dateMaj>
</metaData>
';
my $regex = qr/ +<metaData>[\S\s]+<\/metaData>\s/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}