$re = '/ +<metaData>[\S\s]+<\/metaData>\s/';
$str = ' <usedInTechSheet>false</usedInTechSheet>
<usedInCompositionList>false</usedInCompositionList>
<usedInRequestForm>false</usedInRequestForm>
<metaData>
<dateCreation>2014-10-01</dateCreation>
<dateMaj>2021-04-27</dateMaj>
</metaData>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);