re = / +<metaData>[\S\s]+<\/metaData>\s/
str = ' <usedInTechSheet>false</usedInTechSheet>
<usedInCompositionList>false</usedInCompositionList>
<usedInRequestForm>false</usedInRequestForm>
<metaData>
<dateCreation>2014-10-01</dateCreation>
<dateMaj>2021-04-27</dateMaj>
</metaData>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end