using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i:(?<!\S)([a-z]) +((?1))|\G(?!\A) +((?1))\b)";
string substitution = @"$1$2$3";
string input = @"Welcome to the Greater S E A T T L E area";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}