const regex = /(?i:(?<!\S)([a-z]) +((?1))|\G(?!\A) +((?1))\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i:(?<!\\S)([a-z]) +((?1))|\\G(?!\\A) +((?1))\\b)', 'gm')
const str = `Welcome to the Greater S E A T T L E area`;
const subst = `$1$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);