import re
regex = re.compile(r"(?i:(?<!\S)([a-z]) +((?1))|\G(?!\A) +((?1))\b)", flags=re.MULTILINE)
test_str = "Welcome to the Greater S E A T T L E area"
subst = "$1$2$3"
result = regex.sub(subst, test_str)
if result:
print(result)