$re = '/(?i:(?<!\S)([a-z]) +((?1))|\G(?!\A) +((?1))\b)/m';
$str = 'Welcome to the Greater S E A T T L E area';
$subst = "$1$2$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;