re = /(?i:(?<!\S)([a-z]) +((?1))|\G(?!\A) +((?1))\b)/m
str = 'Welcome to the Greater S E A T T L E area'
subst = '$1$2$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result