import Foundation
let pattern = #"(?i:(?<!\S)([a-z]) +((?1))|\G(?!\A) +((?1))\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Welcome to the Greater S E A T T L E area"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)