use strict;
my $str = 'Welcome to the Greater S E A T T L E area';
my $regex = qr/(?i:(?<!\S)([a-z]) +((?1))|\G(?!\A) +((?1))\b)/mp;
my $subst = '$1$2$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";