#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms){if(?(?={\/?if)|.)*(?={\/if})"
Local $sString = "{if $var1}" & @CRLF & _
" {if $var2}" & @CRLF & _
" {if $var3}{/if}" & @CRLF & _
" {/if}" & @CRLF & _
" {if $var4}" & @CRLF & _
"" & @CRLF & _
" {elseif $var5}" & @CRLF & _
"" & @CRLF & _
" {else}" & @CRLF & _
" {if $var6}{/if}" & @CRLF & _
" {/if}" & @CRLF & _
"" & @CRLF & _
" {if $var7}{/if}" & @CRLF & _
"" & @CRLF & _
"{else}" & @CRLF & _
"" & @CRLF & _
"{/if}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")