using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{if(?(?={\/?if)|.)*(?={\/if})";
string input = @"{if $var1}
{if $var2}
{if $var3}{/if}
{/if}
{if $var4}
{elseif $var5}
{else}
{if $var6}{/if}
{/if}
{if $var7}{/if}
{else}
{/if}";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}