const regex = /{if(?(?={\/?if)|.)*(?={\/if})/ms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{if(?(?={\\\/?if)|.)*(?={\\\/if})', 'ms')
const str = `{if \$var1}
{if \$var2}
{if \$var3}{/if}
{/if}
{if \$var4}
{elseif \$var5}
{else}
{if \$var6}{/if}
{/if}
{if \$var7}{/if}
{else}
{/if}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}