import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{if(?(?=\\{\\/?if)|.)*(?=\\{\\/if\\})";
final String string = "{if $var1}\n"
+ " {if $var2}\n"
+ " {if $var3}{/if}\n"
+ " {/if}\n"
+ " {if $var4}\n\n"
+ " {elseif $var5}\n\n"
+ " {else}\n"
+ " {if $var6}{/if}\n"
+ " {/if}\n\n"
+ " {if $var7}{/if}\n\n"
+ "{else}\n\n"
+ "{/if}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}