use strict;
my $str = '{if $var1}
{if $var2}
{if $var3}{/if}
{/if}
{if $var4}
{elseif $var5}
{else}
{if $var6}{/if}
{/if}
{if $var7}{/if}
{else}
{/if}';
my $regex = qr/{if(?(?={\/?if)|.)*(?={\/if})/msp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}