$re = '/{if(?(?={\/?if)|.)*(?={\/if})/ms';
$str = '{if $var1}
{if $var2}
{if $var3}{/if}
{/if}
{if $var4}
{elseif $var5}
{else}
{if $var6}{/if}
{/if}
{if $var7}{/if}
{else}
{/if}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);