re = /{if(?(?={\/?if)|.)*(?={\/if})/m
str = '{if $var1}
{if $var2}
{if $var3}{/if}
{/if}
{if $var4}
{elseif $var5}
{else}
{if $var6}{/if}
{/if}
{if $var7}{/if}
{else}
{/if}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end