# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"{if(?(?={\/?if)|.)*(?={\/if})"
test_str = ("{if $var1}\n"
" {if $var2}\n"
" {if $var3}{/if}\n"
" {/if}\n"
" {if $var4}\n\n"
" {elseif $var5}\n\n"
" {else}\n"
" {if $var6}{/if}\n"
" {/if}\n\n"
" {if $var7}{/if}\n\n"
"{else}\n\n"
"{/if}")
matches = re.search(regex, test_str, re.MULTILINE | re.DOTALL)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.