import Foundation
let pattern = #"{if(?(?={\/?if)|.)*(?={\/if})"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
{if $var1}
{if $var2}
{if $var3}{/if}
{/if}
{if $var4}
{elseif $var5}
{else}
{if $var6}{/if}
{/if}
{if $var7}{/if}
{else}
{/if}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}