#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\D+)(\d{4})(\d{2})(\d{2})T(\d{2})(\d{2})(\d{2})(\D+)(\d{4})(\d{2})(\d{2})T(\d{2})(\d{2})(\d{2})(\D+)"
Local $sString = "BEGIN:VEVENT\r\n" & @CRLF & _
"DTSTART;VALUE=DATE-TIME:20160124T160000Z\r\n" & @CRLF & _
"DTEND;VALUE=DATE-TIME:20160124T173000Z\r\n" & @CRLF & _
"END:VEVENT\r\n"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")