$re = '/(\D+)(\d{4})(\d{2})(\d{2})T(\d{2})(\d{2})(\d{2})(\D+)(\d{4})(\d{2})(\d{2})T(\d{2})(\d{2})(\d{2})(\D+)/';
$str = 'BEGIN:VEVENT\\r\\n
DTSTART;VALUE=DATE-TIME:20160124T160000Z\\r\\n
DTEND;VALUE=DATE-TIME:20160124T173000Z\\r\\n
END:VEVENT\\r\\n';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);