# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\D+)(\d{4})(\d{2})(\d{2})T(\d{2})(\d{2})(\d{2})(\D+)(\d{4})(\d{2})(\d{2})T(\d{2})(\d{2})(\d{2})(\D+)"
test_str = ("BEGIN:VEVENT\\r\\n\n"
"DTSTART;VALUE=DATE-TIME:20160124T160000Z\\r\\n\n"
"DTEND;VALUE=DATE-TIME:20160124T173000Z\\r\\n\n"
"END:VEVENT\\r\\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.