re = /(\D+)(\d{4})(\d{2})(\d{2})T(\d{2})(\d{2})(\d{2})(\D+)(\d{4})(\d{2})(\d{2})T(\d{2})(\d{2})(\d{2})(\D+)/
str = 'BEGIN:VEVENT\\r\\n
DTSTART;VALUE=DATE-TIME:20160124T160000Z\\r\\n
DTEND;VALUE=DATE-TIME:20160124T173000Z\\r\\n
END:VEVENT\\r\\n'
# Print the match result
str.match(re) do |match|
puts match.to_s
end