// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\D+)(\d{4})(\d{2})(\d{2})T(\d{2})(\d{2})(\d{2})(\D+)(\d{4})(\d{2})(\d{2})T(\d{2})(\d{2})(\d{2})(\D+)").unwrap();
let string = "BEGIN:VEVENT\\r\\n
DTSTART;VALUE=DATE-TIME:20160124T160000Z\\r\\n
DTEND;VALUE=DATE-TIME:20160124T173000Z\\r\\n
END:VEVENT\\r\\n";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}