import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\D+)(\\d{4})(\\d{2})(\\d{2})T(\\d{2})(\\d{2})(\\d{2})(\\D+)(\\d{4})(\\d{2})(\\d{2})T(\\d{2})(\\d{2})(\\d{2})(\\D+)";
final String string = "BEGIN:VEVENT\\r\\n\n"
+ "DTSTART;VALUE=DATE-TIME:20160124T160000Z\\r\\n\n"
+ "DTEND;VALUE=DATE-TIME:20160124T173000Z\\r\\n\n"
+ "END:VEVENT\\r\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}