use strict;
my $str = 'BEGIN:VEVENT\\r\\n
DTSTART;VALUE=DATE-TIME:20160124T160000Z\\r\\n
DTEND;VALUE=DATE-TIME:20160124T173000Z\\r\\n
END:VEVENT\\r\\n';
my $regex = qr/(\D+)(\d{4})(\d{2})(\d{2})T(\d{2})(\d{2})(\d{2})(\D+)(\d{4})(\d{2})(\d{2})T(\d{2})(\d{2})(\d{2})(\D+)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}