const regex = /(\D+)(\d{4})(\d{2})(\d{2})T(\d{2})(\d{2})(\d{2})(\D+)(\d{4})(\d{2})(\d{2})T(\d{2})(\d{2})(\d{2})(\D+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\D+)(\\d{4})(\\d{2})(\\d{2})T(\\d{2})(\\d{2})(\\d{2})(\\D+)(\\d{4})(\\d{2})(\\d{2})T(\\d{2})(\\d{2})(\\d{2})(\\D+)', '')
const str = `BEGIN:VEVENT\\r\\n
DTSTART;VALUE=DATE-TIME:20160124T160000Z\\r\\n
DTEND;VALUE=DATE-TIME:20160124T173000Z\\r\\n
END:VEVENT\\r\\n`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}