package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\D+)(\d{4})(\d{2})(\d{2})T(\d{2})(\d{2})(\d{2})(\D+)(\d{4})(\d{2})(\d{2})T(\d{2})(\d{2})(\d{2})(\D+)`)
var str = `BEGIN:VEVENT\r\n
DTSTART;VALUE=DATE-TIME:20160124T160000Z\r\n
DTEND;VALUE=DATE-TIME:20160124T173000Z\r\n
END:VEVENT\r\n`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}