#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?:\+39)|(?:0039))+[0-9. ]+"
Local $sString = "Something here" & @CRLF & _
"" & @CRLF & _
"and something here 9, but (I have something here as well), 123456, Hi guys!" & @CRLF & _
"" & @CRLF & _
"+39.1234.325636 test +39.321.1234567 test 0039.1234.325636 test 0039.321.1234567" & @CRLF & _
"" & @CRLF & _
"0039 1234 325636 test 0039 321 1234567" & @CRLF & _
"" & @CRLF & _
"sex male | date of birth 16/12/1927 | nationality italian" & @CRLF & _
"" & @CRLF & _
"some stuff"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")