import Foundation
let pattern = #"((?:\+39)|(?:0039))+[0-9. ]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Something here
and something here 9, but (I have something here as well), 123456, Hi guys!
+39.1234.325636 test +39.321.1234567 test 0039.1234.325636 test 0039.321.1234567
0039 1234 325636 test 0039 321 1234567
sex male | date of birth 16/12/1927 | nationality italian
some stuff
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)