use strict;
my $str = 'Something here
and something here 9, but (I have something here as well), 123456, Hi guys!
+39.1234.325636 test +39.321.1234567 test 0039.1234.325636 test 0039.321.1234567
0039 1234 325636 test 0039 321 1234567
sex male | date of birth 16/12/1927 | nationality italian
some stuff';
my $regex = qr/((?:\+39)|(?:0039))+[0-9. ]+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}