using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\+39)|(?:0039))+[0-9. ]+";
string input = @"Something here
and something here 9, but (I have something here as well), 123456, Hi guys!
+39.1234.325636 test +39.321.1234567 test 0039.1234.325636 test 0039.321.1234567
0039 1234 325636 test 0039 321 1234567
sex male | date of birth 16/12/1927 | nationality italian
some stuff";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}