package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?:\+39)|(?:0039))+[0-9. ]+`)
var str = `Something here
and something here 9, but (I have something here as well), 123456, Hi guys!
+39.1234.325636 test +39.321.1234567 test 0039.1234.325636 test 0039.321.1234567
0039 1234 325636 test 0039 321 1234567
sex male | date of birth 16/12/1927 | nationality italian
some stuff`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}