# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:\+39)|(?:0039))+[0-9. ]+"
test_str = ("Something here\n\n"
"and something here 9, but (I have something here as well), 123456, Hi guys!\n\n"
"+39.1234.325636 test +39.321.1234567 test 0039.1234.325636 test 0039.321.1234567\n\n"
"0039 1234 325636 test 0039 321 1234567\n\n"
"sex male | date of birth 16/12/1927 | nationality italian\n\n"
"some stuff")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.