re = /((?:\+39)|(?:0039))+[0-9. ]+/m
str = 'Something here
and something here 9, but (I have something here as well), 123456, Hi guys!
+39.1234.325636 test +39.321.1234567 test 0039.1234.325636 test 0039.321.1234567
0039 1234 325636 test 0039 321 1234567
sex male | date of birth 16/12/1927 | nationality italian
some stuff'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end