import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:\\+39)|(?:0039))+[0-9. ]+";
final String string = "Something here\n\n"
+ "and something here 9, but (I have something here as well), 123456, Hi guys!\n\n"
+ "+39.1234.325636 test +39.321.1234567 test 0039.1234.325636 test 0039.321.1234567\n\n"
+ "0039 1234 325636 test 0039 321 1234567\n\n"
+ "sex male | date of birth 16/12/1927 | nationality italian\n\n"
+ "some stuff";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}