const regex = /((?:\+39)|(?:0039))+[0-9. ]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:\\+39)|(?:0039))+[0-9. ]+', 'gm')
const str = `Something here
and something here 9, but (I have something here as well), 123456, Hi guys!
+39.1234.325636 test +39.321.1234567 test 0039.1234.325636 test 0039.321.1234567
0039 1234 325636 test 0039 321 1234567
sex male | date of birth 16/12/1927 | nationality italian
some stuff`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}