#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(<[^>]+>)(\~data_([^<]+))(<[^>]+>)"
Local $sString = "<element>~DATA_04</element>"
Local $sSubst = "\1<![CDATA[\2]]>\4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)