const regex = /(<[^>]+>)(\~data_([^<]+))(<[^>]+>)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<[^>]+>)(\\~data_([^<]+))(<[^>]+>)', 'gi')
const str = `<element>~DATA_04</element>`;
const subst = `\1<![CDATA[\2]]>\4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);