// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(<[^>]+>)(\~data_([^<]+))(<[^>]+>)").unwrap();
let string = "<element>~DATA_04</element>";
let substitution = "\\1<![CDATA[\\2]]>\\4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}