re = /(<[^>]+>)(\~data_([^<]+))(<[^>]+>)/i
str = '<element>~DATA_04</element>'
subst = '\\1<![CDATA[\\2]]>\\4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result