$re = '/(<[^>]+>)(\~data_([^<]+))(<[^>]+>)/i';
$str = '<element>~DATA_04</element>';
$subst = "\1<![CDATA[\2]]>\4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;