use strict;
my $str = '<element>~DATA_04</element>';
my $regex = qr/(<[^>]+>)(\~data_([^<]+))(<[^>]+>)/ip;
my $subst = '\\1<![CDATA[\\2]]>\\4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";