import re
regex = re.compile(r"(<[^>]+>)(\~data_([^<]+))(<[^>]+>)", flags=re.IGNORECASE)
test_str = "<element>~DATA_04</element>"
subst = "\\1<![CDATA[\\2]]>\\4"
result = regex.sub(subst, test_str)
if result:
print(result)